List index out of bounds

Help, problems, suggestions about Waterski Scoring software
villep
Posts: 48
Joined: Mon May 23, 2005 10:04 pm
Location: Sweden
Contact:

List index out of bounds

Post by villep » Mon Aug 19, 2013 9:35 pm

Hi
A minor bug report that I think I have isolated even if I am not fully shore how to repeat.

Sometimes I get an List index out of bounds.
I get this when opening the Display start list and at the same time having Individual classification open.

Setup
* The different classes has different number of skiers
* In the start list or the result I have marked an skier with higher index then the number of skers in the other start list.
* I change class in the classification tab when the start list is closed.
- The error comes when pressing Display start list

Uninformatively I have not found an step by step how to repeat, but it happened 4 times during the competition and now when testing I have been able to repeat it once (after 10 open/close/change step, but then I have tested 100 times without being able to repeat)

So hopefully you can find an error based on this information or else since the error is handled it cause no problem.

Best regards
Vilhelm Persson

emmanuel
Site Admin
Posts: 220
Joined: Fri May 20, 2005 8:34 am
Contact:

Re: List index out of bounds

Post by emmanuel » Tue Aug 20, 2013 8:14 am

villep wrote:Hi
A minor bug report that I think I have isolated even if I am not fully shore how to repeat.

Sometimes I get an List index out of bounds.
I get this when opening the Display start list and at the same time having Individual classification open.

Setup
* The different classes has different number of skiers
* In the start list or the result I have marked an skier with higher index then the number of skers in the other start list.
* I change class in the classification tab when the start list is closed.
- The error comes when pressing Display start list

Uninformatively I have not found an step by step how to repeat, but it happened 4 times during the competition and now when testing I have been able to repeat it once (after 10 open/close/change step, but then I have tested 100 times without being able to repeat)

So hopefully you can find an error based on this information or else since the error is handled it cause no problem.

Best regards
Vilhelm Persson
Hi Vilhelm,

I just tried to reproduce this bug, but did not succeed.
I checked some of the code, but did not find where this could happen so far.
I will keep an eye on that.

If you manage to reproduce this bug, please send the file (upload attachment), and describe the steps to reproduce it.

Regards,
Emmanuel

Post Reply